linux mysql. Как установить heidisql на linux


Heidisql это многофункциональное свободно распространяемое приложение с открытым исходным кодом, которое позволяем просматривать, редактировать данные, в таблицах баз данных, а так же многое другое.
К сожалению данный Mysql клиент доступен только для Windows операционных систем.

К счастью на Linux есть такая программа как Wine.

Wine - это программа, позволяющая запускать Windows приложения под операционной системой Linux и Unix подобными операционными система.

И так, приступим к установке:

В первую очередь необходимо открыть терминал(консоль) и выполнить команду:
sudo apt-get install wine


Так же вы можете посмотреть как установить свежую версию wine на официальном сайте ubuntu.
Далее переходим на официальный сайт Heidisql и качаем клиент heidisql

После того как клиент будет скачан, можно приступить к установке.
Для этого выполним в терминале команду:
sudo wine [путь до heidisql]

В моем случае путь и команды были такими:
sudo wine /home/fixlix/Загрузки/HeidiSQL_9.5.0.5196_Setup.exe

Далее начнется установка программного обеспечения Heidisql.
По окончанию установки запускаем клиент и пользуется.

Комментариев 4

  1. Офлайн
    sublapsa 24 марта 2019 13:18
    При попытке установить вылетает ошибка
    wine: '/home/sub' is not owned by you, refusing to create a configuration directory there

    Что это? Как поправить?
  2. Офлайн
    Fixlix 24 марта 2019 13:30
    Цитата: sublapsa
    При попытке установить вылетает ошибка
    wine: '/home/sub' is not owned by you, refusing to create a configuration directory there

    Что это? Как поправить?

    Я думаю можно попробовать выдать права пользователю на папку home/sub:
    sudo chown -R sub /home/sub

    Ну или попробовать запустить установку heidisql без sudo:
    wine HeidiSQL_9.5.0.5196_Setup.exe
    1. Офлайн
      sublapsa 24 марта 2019 13:35
      Помогла установка wine без sudo.
      Но при запуске в консоли вылетела ошибка
      0036:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.
      1. Офлайн
        Fixlix 24 марта 2019 13:40
        Попробуйте установить winbind:
        sudo apt install winbind

        Должно помочь
Информация
Посетители, находящиеся в группе Гости, не могут оставлять комментарии к данной публикации.